By 6 years ago in Blogging Google

Has Google Stopped Indexing Blogs?

This might seem an overly dramatic headline but it seems that Google is having trouble indexing certain WordPress blogs.

DaveN spotted the issue first when he realised his new blog posts were missing from the Google search index even though Google had spidered them and included them in the blog search results.

In what might be a related issue Google has been alerting people (myself included on 2 WordPress blogs) to “General HTTP Errors” in the Webmaster Tools console.

As far as I can tell from looking at crawl logs Google accessed these pages just fine so why are the errors appearing and what are they?

By Patrick Altoft. at 2:55PM on Monday, 15 Sep 2008

Patrick is the Director of Strategy at Branded3 and has spent the last 11 years working on the SEO strategies of some of the UK's largest brands. Patrick’s SEO knowledge and experience is highly regarded by many, and he’s regularly invited to speak at the world’s biggest search conferences and events. Follow Patrick Altoft on Twitter.

comments

26 Responses to “Has Google Stopped Indexing Blogs?”

  1. Tom says:

    I’m getting general HTTP errors in my WMC for distilled too – though I’m actually seeing it for some regular HTML pages as well as individual blog posts

  2. DazzlinDonna says:

    Yep, I have those same errors for SEO Scoop as well. I’m guessing it’s a reporting glitch, but maybe it’s an actual problem. Hope G either fixes – or tells us more.

  3. I just went into webmaster tools and get the same thing. Some of the posts though are older posts so I am not sure what the problem is. I was worried about the links themselves so I clicked through and they are there.

    Anyway, I created a post on the weekend that should have ranked very high for “Huricane Ike Cancun” looked the next day and I was not in the first 30 results so I am apt to agree with you about the indexing of new blog posts.

    Hopefully this is just an error on Googles side

  4. Ken Jones says:

    I noticed the same thing on my WM Tools report a couple of days ago, but just assumed it was a temporary glitch because the date of the error coincided with the day last week when I installed the latest WP update. I put up a new post later that day and G’s cache of my homepage shows that post (and a cache time that’s only a couple of minutes after I hit the publish button) so it all seemed hunky-dory after that.
    Haven’t had any other crawl errors reported, but if it’s affecting a lot of other WP users as well it might be something more serious. I’ll have to have a deeper look into my stats and see if it shows up anything untoward.

  5. Actually, I’d say it’s your reports that are in error.

    Blogstorm looks fine.
    Dave Naylor looks fine.
    DazzlinDonna looks fine.

    Everything is okay. Just another glitch in google’s products. ;)

  6. imnotadoctor says:

    I am having this issue as well on my wordpress blog. How odd.

  7. Dan says:

    Conspiracy alert!! Only issues with WP and not Blogger sites? Hmmmm….

  8. I can see half a dozen of those general http errors for my site all dated September 9, I suspect it’s a transient error, but more to the point all the pages in question are #1 in the Google SERP for their titles

  9. [...] “Has Google Stopped Indexing Blogs?” (That relates to me.. I own this blog!) [...]

  10. don says:

    Interesting. I was having similar issues and thought, it was my developer’s fault.
    And like Dave above, those particular titles were in number one slots.

    In my case I have been using wordpress as a CMS. Maybe its time to abandon ship and go over to DRUPAL.

  11. Jenin says:

    I seem to be having a similar problem and I’m really frustrated. Since the 9th of September it appears that google has stopped indexing my new blog posts. I don’t know what to do about this. At first I thought it was a problem with my blog, but I realise that others are facing a similar problem. Any news on whether Google has acknowledged this problem or made any announcements about how it will be solved??

  12. I hardly think that Google is going to stop indexing blogs..

    They are accounting for more internet content than any other type of media on the internet. I’m sure it’s just something like a feedburner glitch and will be over soon. :)

  13. Good to hear it’s probably just a tool error as opposed Google not indexing them anymore..phew!

  14. I also have the same errors in my Log

  15. [...] I have seen some prominent SEO Site that is also having problem with Google indexing here and here, The screen capture shown below are shots taken today. Upon checking those Errors, I can say that [...]

  16. I see the errors for another of my sites that isn’t strictly speaking a blog and doesn’t run WordPress

  17. Got the same generic HTTP errors and I use Dotclear. Google is also very slow to refresh the index pages which is unusual as my blog has some decent popularity.

  18. Tom Goering says:

    My blog stopped having pages indexed in Google Blog Search the day I was excepted for AdSense for Feeds. Blog Search updates from the site’s feed.

    My posts however do make it to the regular index on Googlebots regular rounds.

    I deactivated Feedsmith in wordpress and everything is back to normal (except the benefits of feedsmith that is)

  19. DazzlinDonna says:

    I’ve made this comment elsewhere, but I think it deserves to be shared here as well: One seorefugee member found his blog indexing issue to be related to the switch to adsense for feedburner. (see http://www.seorefugee.com/forums/showthread.php?t=10624) Perhaps this will help at least some folks track down their problems.

  20. JohnMu says:

    Hi Patrick, the “General HTTP Errors” should be disappearing from your account soon — it seems that this was an intermittent reporting issue in Webmaster Tools. It’s not an error you need to be worried about, sorry for the scare! If it doesn’t disappear from your account in the next day or so, it’d be great if you could post in the Webmaster Help groups at http://groups.google.com/group/Google_Webmaster_Help-Tools/browse_thread/thread/d40a45ed11f1534e/

  21. Peter Young says:

    Had the same with a number of wordpress blogs – both .com and hosted.

    Is the problem merely with WordPress blogs, or have any other blog vendors been affected?

  22. Jon says:

    I had one http error on 8th September, but have been OK since. I’m still on WP 2.5 – wonder if the version makes any difference?

    Cheers, Jon

  23. Apparently, Google is now aware of this issue. To quote from JohnMu, who is presumably staff: “This appears to be an issue in the reporting side of things in
    Webmaster Tools. As far as I know, the “General HTTP errors” should be
    gone soon :-). Thanks for bringing it to our attention, you guys are
    the greatest!!”

    http://groups.google.com/group/Google_Webmaster_Help-Tools/browse_thread/thread/d40a45ed11f1534e#

  24. I had several HTTP errors for both of the blogs I actively run last week. Google crawls one of the blogs immediately after posts are made and new posts generally go straight onto the blog search results with the web search results soon after. In the past few days I’ve noticed significantly more lag than I’d become accustomed to.

  25. [...] Has Google Stopped Indexing Blogs? [...]

  26. I don’t know about that, but I do know that recently a site of mine took some severe drops in Google search engine results pages. So something is going on!

Leave a Reply